summaryrefslogtreecommitdiff
path: root/overlay/Makefile.am
diff options
context:
space:
mode:
authorLionel Landwerlin <lionel.g.landwerlin@intel.com>2017-12-08 11:33:21 +0000
committerLionel Landwerlin <lionel.g.landwerlin@intel.com>2017-12-08 17:21:17 +0000
commitefef51dd75c8f41aa6ba08e806f8c81501eb7ee7 (patch)
tree4407c0ccd1049972820b4cea3d13f07280706cdd /overlay/Makefile.am
parent39ac6b89e9e51b55886181aabd91739ea1e61adb (diff)
debugger/overlay/tools: make sure to include embedded drm-uapi headers
Headers from lib/ depend on drm uapi headers. Since we started embedding them, let's make sure to pull them first. We still depend on libdrm in places, we don't want the system headers from libdrm to be included prior to the embedded ones. v2: Fix debugger/overlay (Lionel) v3: More fixes in lib/tests (Lionel) Signed-off-by: Lionel Landwerlin <lionel.g.landwerlin@intel.com> Reviewed-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'overlay/Makefile.am')
-rw-r--r--overlay/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/overlay/Makefile.am b/overlay/Makefile.am
index f49f54ac..fca04cae 100644
--- a/overlay/Makefile.am
+++ b/overlay/Makefile.am
@@ -2,7 +2,7 @@ if BUILD_OVERLAY
bin_PROGRAMS = intel-gpu-overlay
endif
-AM_CPPFLAGS = -I.
+AM_CPPFLAGS = -I. -I$(top_srcdir)/include/drm-uapi
AM_CFLAGS = $(DRM_CFLAGS) $(PCIACCESS_CFLAGS) $(CWARNFLAGS) \
$(CAIRO_CFLAGS) $(OVERLAY_CFLAGS) $(WERROR_CFLAGS) -I$(srcdir)/../lib
LDADD = $(DRM_LIBS) $(PCIACCESS_LIBS) $(CAIRO_LIBS) $(OVERLAY_LIBS) $(top_builddir)/lib/libigt_perf.la