summaryrefslogtreecommitdiff
path: root/overlay/Makefile.am
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2013-08-17 11:12:07 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2013-08-17 11:21:51 +0100
commitf9a50de3dcc501e930de6c60983a4feb57121e7e (patch)
treee2a65ef9a1ce5c15faf8e95e0337e821e2579ac7 /overlay/Makefile.am
parent7df9caeea1606b4f0272de35f0d7f70eedd5ec30 (diff)
Introduce intel-gpu-overlay
A realtime display of GPU activity. Note, this is just at the point of minimum usability... Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'overlay/Makefile.am')
-rw-r--r--overlay/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/overlay/Makefile.am b/overlay/Makefile.am
new file mode 100644
index 00000000..10820bdf
--- /dev/null
+++ b/overlay/Makefile.am
@@ -0,0 +1,28 @@
+if BUILD_OVERLAY
+bin_PROGRAMS = intel-gpu-overlay
+endif
+
+AM_CPPFLAGS = -I.
+AM_CFLAGS = $(DRM_CFLAGS) $(PCIACCESS_CFLAGS) $(CWARNFLAGS) $(CAIRO_CFLAGS) $(OVERLAY_CFLAGS)
+LDADD = $(DRM_LIBS) $(PCIACCESS_LIBS) $(CAIRO_LIBS) $(OVERLAY_LIBS)
+
+intel_gpu_overlay_SOURCES = \
+ i915_pciids.h \
+ overlay.h \
+ overlay.c \
+ chart.h \
+ chart.c \
+ gem-objects.h \
+ gem-objects.c \
+ gpu-top.h \
+ gpu-top.c \
+ igfx.h \
+ igfx.c \
+ x11/dri2.c \
+ x11/dri2.h \
+ x11/rgb2yuv.c \
+ x11/rgb2yuv.h \
+ x11/x11-overlay.c \
+ $(NULL)
+
+EXTRA_DIST=README