summaryrefslogtreecommitdiff
path: root/overlay/meson.build
diff options
context:
space:
mode:
authorTvrtko Ursulin <tvrtko.ursulin@intel.com>2017-09-13 17:38:16 +0100
committerTvrtko Ursulin <tvrtko.ursulin@intel.com>2017-11-22 11:17:48 +0000
commita688deceae195aec863d8de45bdaefb251927c89 (patch)
tree80f916af851ea53ad295a525efa58e8661e176d1 /overlay/meson.build
parent42ee3f94f2c5c3258930c22da7c1b497dd635346 (diff)
intel-gpu-overlay: Move local perf implementation to a library
Idea is to avoid duplication across multiple users in upcoming patches. v2: Commit message and use a separate library instead of piggy- backing to libintel_tools. (Chris Wilson) v3: Add Petri's meson build recipe. Signed-off-by: Tvrtko Ursulin <tvrtko.ursulin@intel.com> Cc: Petri Latvala <petri.latvala@intel.com> Reviewed-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'overlay/meson.build')
-rw-r--r--overlay/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/overlay/meson.build b/overlay/meson.build
index a92ef895..ffc011cc 100644
--- a/overlay/meson.build
+++ b/overlay/meson.build
@@ -10,7 +10,6 @@ gpu_overlay_src = [
'gpu-freq.c',
'igfx.c',
'overlay.c',
- 'perf.c',
'power.c',
'rc6.c',
]
@@ -56,5 +55,6 @@ if xrandr.found() and cairo.found()
include_directories : inc,
c_args : gpu_overlay_cflags,
dependencies : gpu_overlay_deps,
+ link_with : lib_igt_perf,
install : true)
endif