summaryrefslogtreecommitdiff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorTvrtko Ursulin <tvrtko.ursulin@intel.com>2017-02-22 09:54:27 +0000
committerTvrtko Ursulin <tvrtko.ursulin@intel.com>2017-04-25 14:53:46 +0100
commit544e9f8368a95f758887eb88b5c92a77abbd11dc (patch)
tree4f98db3c55d3e5fb33761d2451a1acfdec9440db /scripts/Makefile.am
parent054eb1abecd1cce2e4ee0516f3ff8a67a35dca22 (diff)
igt/scripts: trace.pl to parse the i915 tracepoints
Given a log file created via perf with some interesting trace events enabled, this tool can generate the timeline graph of requests getting queued, their dependencies resolved, sent to the GPU for executing and finally completed. This can be useful when analyzing certain classes of performance issues. More help is available in the tool itself. The tool will also calculate some overall per engine statistics, like total time engine was idle and similar. v2: * Address missing git add. * Make html output optional (--html switch) and by default just output aggregated per engine stats to stdout. v3: * Added --trace option which invokes perf with the correct options automatically. * Added --avg-delay-stats which prints averages for things like waiting on ready, waiting on GPU and context save duration. * Fix warnings when no waits on an engine. * Correct help text. v4: * Add --squash-ctx-id to substract engine id from ctx id when parsing to make it easier to identify which context is which with new i915 ctx id allocation scheme. * Reconstruct request_out events where they are missing. Signed-off-by: Tvrtko Ursulin <tvrtko.ursulin@intel.com> Cc: Chris Wilson <chris@chris-wilson.co.uk> Cc: Harri Syrja <harri.syrja@intel.com> Cc: Krzysztof E Olinski <krzysztof.e.olinski@intel.com>
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 85d4a5cf..64171529 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -1,2 +1,2 @@
-dist_noinst_SCRIPTS = intel-gfx-trybot who.sh run-tests.sh
+dist_noinst_SCRIPTS = intel-gfx-trybot who.sh run-tests.sh trace.pl
noinst_PYTHON = throttle.py