summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorPetri Latvala <petri.latvala@intel.com>2017-08-25 13:13:51 +0300
committerPetri Latvala <petri.latvala@intel.com>2017-09-22 12:06:35 +0300
commit23b7c99c8f6b2da9f624d4f0c40fe1355d5a2dcc (patch)
tree85e9c5731953e98b18860acb03a47755e575aac5 /tests/Makefile.am
parent74778b83f602f811512269ecf8ddfc08fcfdd4f0 (diff)
tests/Makefile.am: Install test-list*.txt to libexecdir
Piglit expects test-list*.txt files to be in the same directory as the test binaries. Installing non-executable files to libexecdir requires going around some of autotools' sanity checks. This change should make 'make install':ed IGT runnable with piglit. Signed-off-by: Petri Latvala <petri.latvala@intel.com> Cc: Tomi Sarvela <tomi.p.sarvela@intel.com> Cc: Arkadiusz Hiler <arkadiusz.hiler@intel.com> Reviewed-by: Arkadiusz Hiler <arkadiusz.hiler@intel.com> Tested-by: Arkadiusz Hiler <arkadiusz.hiler@intel.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 39ca3960..1cea4036 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -51,6 +51,16 @@ pkglibexec_PROGRAMS = \
$(TESTS_progs_X) \
$(NULL)
+# Piglit expects test-list*.txt to be in the same directory as the
+# tests. pkglibexec_DATA is an invalid combo to autotools, so work
+# around that by defining a new directory variable that is the same as
+# libexec directory and install the .txt files there.
+wrap_libexecdir = $(pkglibexecdir)
+wrap_libexec_DATA = \
+ test-list.txt \
+ test-list-full.txt \
+ $(NULL)
+
dist_pkglibexec_SCRIPTS = \
$(TESTS_scripts) \
$(scripts) \
@@ -64,8 +74,6 @@ all-local: .gitignore
.gitignore: Makefile.sources
@echo "$(pkglibexec_PROGRAMS) $(HANG) test-list.txt test-list-full.txt /.gitignore" | sed 's/\s\+/\n/g' | sort > $@
-pkgdata_DATA = test-list.txt test-list-full.txt
-
EXTRA_PROGRAMS = $(HANG)
EXTRA_DIST = $(common_files) $(check_SCRIPTS)