summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2016-07-05 15:40:44 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2016-07-05 15:59:27 +0100
commit3ef6913e0fc1c5540bbe32263fde25c2331a8545 (patch)
treeef181f4d0272a6c7f9801d1f6f5290f247b23629 /tests/Makefile.am
parent8a0b93743646312f49e1eebfaf41495875ffbdf2 (diff)
igt/gem_sync: Try and race the bottom-half
In light of a bug in intel_breadcrumbs where we missed the interrupt when a new bottom half was installed and raced with the old bottom half being signaled, try and recreate that race. Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index c2c2025e..102b8a64 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -88,6 +88,8 @@ gem_mmap_gtt_CFLAGS = $(AM_CFLAGS) $(THREAD_CFLAGS)
gem_mmap_gtt_LDADD = $(LDADD) -lpthread
gem_mmap_wc_CFLAGS = $(AM_CFLAGS) $(THREAD_CFLAGS)
gem_mmap_wc_LDADD = $(LDADD) -lpthread
+gem_sync_CFLAGS = $(AM_CFLAGS) $(THREAD_CFLAGS)
+gem_sync_LDADD = $(LDADD) -lpthread
gem_threaded_access_tiled_CFLAGS = $(AM_CFLAGS) $(THREAD_CFLAGS)
gem_threaded_access_tiled_LDADD = $(LDADD) -lpthread
gem_tiled_swapping_CFLAGS = $(AM_CFLAGS) $(THREAD_CFLAGS)