summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorPaul Kocialkowski <paul.kocialkowski@linux.intel.com>2017-08-22 11:26:58 +0300
committerLyude <lyude@redhat.com>2017-08-22 13:28:39 -0400
commit42b42c99cd9d1b890807ae97cbd1c593396ae051 (patch)
tree0744ac5542d836abe0783a3046b81fb6ae9f7a9e /tests/Makefile.am
parent4524a8951348a31ae5dabfc4c69f2a835034ec3e (diff)
tests/Makefile.am: Wrap audio test with dedicated conditional
This uses the dedicated HAVE_AUDIO conditional, that depends on both ALSA and GSL, for wrapping the audio test. This makes the wrapping consistent with what is done for the chamelium test. Signed-off-by: Paul Kocialkowski <paul.kocialkowski@linux.intel.com> Reviewed-by: Lyude Paul <lyude@redhat.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am4
1 files changed, 1 insertions, 3 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 471f3818..726e2b27 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -20,13 +20,11 @@ TESTS_progs += \
$(NULL)
endif
-if HAVE_ALSA
-if HAVE_GSL
+if HAVE_AUDIO
TESTS_progs += \
audio \
$(NULL)
endif
-endif
if BUILD_TESTS