summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorOscar Mateo <oscar.mateo@intel.com>2013-11-12 11:50:37 +0000
committerDaniel Vetter <daniel.vetter@ffwll.ch>2013-11-12 12:01:09 +0100
commit4c7d5a52a7f4d79061e6cbb4627df3c194958fff (patch)
tree695fcbf0f688bad9e1028fbe75fde76408e5d48d /tests/Makefile.am
parentd80c6bdedba451adff843295367ebcd3d5e3b0c7 (diff)
build: Move logic to tests/Makefile.am and away from Makefile.sources
Makefile.sources is just a listing with all the sources, and the logic to use these sources goes into either Makefile.am (automake) or Android.mk (make). Signed-off-by: Oscar Mateo <oscar.mateo@intel.com> Signed-off-by: Daniel Vetter <daniel.vetter@ffwll.ch>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 9e1b13fa..8e293f75 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,5 +1,9 @@
include Makefile.sources
+if HAVE_NOUVEAU
+ TESTS_progs_M += $(NOUVEAU_TESTS_M)
+endif
+
if BUILD_TESTS
list-single-tests:
@echo TESTLIST