summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorBen Widawsky <benjamin.widawsky@intel.com>2013-10-29 20:01:14 -0700
committerBen Widawsky <benjamin.widawsky@intel.com>2013-10-29 20:01:36 -0700
commit5382aca1afb33614270c536835e3da61b4e2d123 (patch)
tree056ee9941be996fda58bf751e2c3347e8df057aa /tests/Makefile.am
parent8f771f3facae133bb72216fa05c74bc817920b6d (diff)
gem_close_race: Fix linker flags
Seems the -lpthread was missed in commit 8f771f3facae133bb72216fa05c74bc817920b6d Author: Chris Wilson <chris@chris-wilson.co.uk> Date: Tue Oct 29 14:21:29 2013 +0000 gem_close_race: Also test random closing of active fd Signed-off-by: Ben Widawsky <ben@bwidawsk.net>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index e9e37a63..4ba1d43f 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -216,6 +216,7 @@ TESTS_progs += testdisplay
LDADD += $(CAIRO_LIBS) $(LIBUDEV_LIBS) $(GLIB_LIBS)
AM_CFLAGS += $(CAIRO_CFLAGS) $(LIBUDEV_CFLAGS) $(GLIB_CFLAGS)
+gem_close_race_LDADD = $(LDADD) -lpthread
gem_fence_thrash_CFLAGS = $(AM_CFLAGS) $(THREAD_CFLAGS)
gem_fence_thrash_LDADD = $(LDADD) -lpthread
gem_flink_race_LDADD = $(LDADD) -lpthread