summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorDamien Lespiau <damien.lespiau@intel.com>2015-07-02 11:24:02 +0100
committerDamien Lespiau <damien.lespiau@intel.com>2015-07-02 11:54:17 +0100
commit64295c67e908d59606fafe35e2d2363802c7faec (patch)
tree99b58758b8ddd54a8e8472e28a25ad1a124be93f /tests/Makefile.am
parente5653d5f1d1b349ec320b056d3e6e17008c256a7 (diff)
build: Add -lm to tests
Since the introduction of igt_stats and its usage in gem_exec_nop, we need to link the tests against libm. My rebasing bot complained when linking gem_exec_nop: lib/igt_stats.c:492: undefined reference to `sqrt' Signed-off-by: Damien Lespiau <damien.lespiau@intel.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index d5fb4fdb..dcac2f32 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -50,7 +50,7 @@ AM_CFLAGS = $(DRM_CFLAGS) $(CWARNFLAGS) $(DEBUG_CFLAGS)\
LDADD = ../lib/libintel_tools.la $(PCIACCESS_LIBS) $(DRM_LIBS) $(LIBUNWIND_LIBS)
-LDADD += $(CAIRO_LIBS) $(LIBUDEV_LIBS) $(GLIB_LIBS)
+LDADD += $(CAIRO_LIBS) $(LIBUDEV_LIBS) $(GLIB_LIBS) -lm
AM_CFLAGS += $(CAIRO_CFLAGS) $(LIBUDEV_CFLAGS) $(GLIB_CFLAGS)
drm_import_export_CFLAGS = $(AM_CFLAGS) $(THREAD_CFLAGS)