summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2019-02-14 16:57:11 +0000
committerChris Wilson <chris@chris-wilson.co.uk>2019-02-17 20:54:44 +0000
commit6727e17c00b2ad0a801f96fc8a2afe404b95ec88 (patch)
tree7f4d965e2cddf3a5f33fc7b3871f6dee466c6ee3 /tests/Makefile.am
parent7802324e86ddf947cba847e910f75b1a8affe8d7 (diff)
i915/gem_create: Verify that all new objects are clear
The kernel must not return stale information back to userspace when they create a new object. For that purpose, we always clear objects on creation, so verify that this is so. Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk> Cc: Matthew Auld <matthew.auld@intel.com> Reviewed-by: Matthew Auld <matthew.auld@intel.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 24ee8514..c5dd210c 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -95,6 +95,8 @@ AM_LDFLAGS = -Wl,--as-needed
drm_import_export_CFLAGS = $(AM_CFLAGS) $(THREAD_CFLAGS)
drm_import_export_LDADD = $(LDADD) -lpthread
+gem_create_CFLAGS = $(AM_CFLAGS) $(THREAD_CFLAGS)
+gem_create_LDADD = $(LDADD) -lpthread
gem_close_race_CFLAGS = $(AM_CFLAGS) $(THREAD_CFLAGS)
gem_close_race_LDADD = $(LDADD) -lpthread
gem_ctx_thrash_CFLAGS = $(AM_CFLAGS) $(THREAD_CFLAGS)