summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authormarius vlad <marius.c.vlad@intel.com>2016-05-10 17:32:15 +0300
committerMarius Vlad <marius.c.vlad@intel.com>2016-05-11 18:22:05 +0300
commit701d8fdb363443453c4b613e9180f75ad36a7321 (patch)
tree200be95af16c037a99807fadcd764f736db482c1 /tests/Makefile.am
parent2d432fc5773df17f04283f4780dab161dd2e1c85 (diff)
benchmarks/, overlay/, demos/, tools/, tests/: Add optional Werror.
v2: Initially added Werror by default. Make it optional so it doesn't break android build and (potential) distros maintaing the package (Hinted by Damien Lespiau). --enable-werror will enable -Werror compiler flag. Signed-off-by: Marius Vlad <marius.c.vlad@intel.com> Acked-by: Damien Lespiau <damien.lespiau@intel.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 45e33598..32b91155 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -59,7 +59,7 @@ AM_CFLAGS = $(DRM_CFLAGS) $(CWARNFLAGS) $(DEBUG_CFLAGS)\
-include "$(srcdir)/../lib/check-ndebug.h" \
-DIGT_SRCDIR=\""$(abs_srcdir)"\" \
-DIGT_DATADIR=\""$(pkgdatadir)"\" \
- $(LIBUNWIND_CFLAGS) \
+ $(LIBUNWIND_CFLAGS) $(WERROR_CFLAGS) \
$(NULL)
LDADD = ../lib/libintel_tools.la $(GLIB_LIBS)