summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorPetri Latvala <petri.latvala@intel.com>2017-06-08 15:23:09 +0300
committerPetri Latvala <petri.latvala@intel.com>2017-06-09 12:18:31 +0300
commit73bb3fa53e8ebb05a4e4505e2c7fd0a50b0f07c7 (patch)
treef014cc64505436a31fd0cc5bf05a4fa282ab0a28 /tests/Makefile.am
parent0aaa6d1a95d8fe4dc196c3a7ca4a4a973f8a4f7e (diff)
tests: Merge single_kernel_tests and multi_kernel_tests in the build system
The separation of testcases with and without subtests in the build system was used in the past, but now both are handled the same way. Merge them together and finally forget about the difference between TESTS_progs and TESTS_progs_M. Signed-off-by: Petri Latvala <petri.latvala@intel.com> Reviewed-by: Arkadiusz Hiler <arkadiusz.hiler@intel.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am16
1 files changed, 7 insertions, 9 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 12cc6dc4..9a1c7708 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,19 +1,19 @@
include Makefile.sources
if HAVE_LIBDRM_AMDGPU
- TESTS_progs_M += $(AMDGPU_TESTS_M)
+ TESTS_progs += $(AMDGPU_TESTS)
endif
if HAVE_LIBDRM_NOUVEAU
- TESTS_progs_M += $(NOUVEAU_TESTS_M)
+ TESTS_progs += $(NOUVEAU_TESTS)
endif
if HAVE_LIBDRM_VC4
- TESTS_progs_M += $(VC4_TESTS_M)
+ TESTS_progs += $(VC4_TESTS)
endif
if HAVE_CHAMELIUM
-TESTS_progs_M += \
+TESTS_progs += \
chamelium \
$(NULL)
endif
@@ -21,12 +21,12 @@ endif
if BUILD_TESTS
test-list.txt: Makefile.sources
@echo TESTLIST > $@
- @echo ${single_kernel_tests} ${multi_kernel_tests} >> $@
+ @echo ${kernel_tests} >> $@
@echo END TESTLIST >> $@
test-list-full.txt: Makefile.sources
@echo TESTLIST > $@
- @echo ${single_kernel_tests} ${multi_kernel_tests} ${extra_multi_kernel_tests} >> $@
+ @echo ${kernel_tests} ${extra_kernel_tests} >> $@
@echo END TESTLIST >> $@
@@ -38,13 +38,11 @@ noinst_PROGRAMS = \
pkglibexec_PROGRAMS = \
gem_stress \
$(TESTS_progs) \
- $(TESTS_progs_M) \
- $(TESTS_progs_XM) \
+ $(TESTS_progs_X) \
$(NULL)
dist_pkglibexec_SCRIPTS = \
$(TESTS_scripts) \
- $(TESTS_scripts_M) \
$(scripts) \
$(NULL)