summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2016-03-22 11:33:41 +0000
committerChris Wilson <chris@chris-wilson.co.uk>2016-03-24 11:25:38 +0000
commit756f3e0cb7e7d7351e3eb955ca782a438c6aa887 (patch)
treec1673509c3b101aa70b03408e252e4cb97021308 /tests/Makefile.am
parenteb572106b4721dcfb6bf873ae40c5200f5369039 (diff)
lib: Add a GPU error detector
If we listen to the uevents from the kernel, we can detect when the GPU hangs. This requires us to fork a helper process to do so and send a signal back to the parent. Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 0ed40f7d..771e9eed 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -56,9 +56,8 @@ AM_CFLAGS = $(DRM_CFLAGS) $(CWARNFLAGS) $(DEBUG_CFLAGS)\
$(LIBUNWIND_CFLAGS) \
$(NULL)
-LDADD = ../lib/libintel_tools.la $(PCIACCESS_LIBS) $(DRM_LIBS) $(LIBUNWIND_LIBS) $(TIMER_LIBS)
+LDADD = ../lib/libintel_tools.la $(GLIB_LIBS)
-LDADD += $(CAIRO_LIBS) $(LIBUDEV_LIBS) $(GLIB_LIBS) -lm
AM_CFLAGS += $(CAIRO_CFLAGS) $(LIBUDEV_CFLAGS) $(GLIB_CFLAGS)
AM_LDFLAGS = -Wl,--as-needed