summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorMarius Vlad <marius.c.vlad@intel.com>2016-08-31 19:59:02 +0300
committerMarius Vlad <marius.c.vlad@intel.com>2016-09-01 09:59:55 +0300
commit75e7a3a8d255a4b925e24939e771af3e7cdf15dc (patch)
tree30b5962f581eb8493ff746776c99469408646394 /tests/Makefile.am
parent7213c3e09621d9708a87d26cda4b1b71fe73d206 (diff)
autotools/: Allow check target to be invoked w/o the need to issue a build.
We need to have the test list generated before running the check target. Migrated igt_command_line.sh to tests/ from lib/tests/, which allows to building the tests and execute the script. This would allow cleaning followed by a make check. Also assembler/ directory needs also to be adjusted in order for this to work. Kept the possibility to invoke tests/igt_command_line.sh to determine which test is failing. Signed-off-by: Marius Vlad <marius.c.vlad@intel.com> Url: https://patchwork.freedesktop.org/series/6539/ Reviewed-By: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 0137597a..d0e758fe 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -50,7 +50,7 @@ all-local: .gitignore
pkgdata_DATA = test-list.txt test-list-full.txt
EXTRA_PROGRAMS = $(HANG)
-EXTRA_DIST = $(common_files)
+EXTRA_DIST = $(common_files) $(check_SCRIPTS)
CLEANFILES = $(EXTRA_PROGRAMS) test-list.txt test-list-full.txt .gitignore