summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorThomas Wood <thomas.wood@intel.com>2015-03-23 11:46:25 +0000
committerThomas Wood <thomas.wood@intel.com>2015-03-26 15:50:05 +0000
commit76dad7f41475347f99e8a8ce6af67020dfd7c0f1 (patch)
tree07f924ef1695f180b9a6e466c6139c3447648474 /tests/Makefile.am
parent277ca2b992c766581ef6ef01ea210808f456fbe0 (diff)
Add default debug flags for tests
Include debugging symbols in tests by default to improve stack traces and also set the compiler optimisation level to improve the debugging experience. Signed-off-by: Thomas Wood <thomas.wood@intel.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 93f41ba9..f45c6c94 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -32,7 +32,7 @@ EXTRA_DIST = $(TESTS_scripts) $(TESTS_scripts_M) $(scripts) $(IMAGES) $(common_f
CLEANFILES = $(EXTRA_PROGRAMS) single-tests.txt multi-tests.txt
-AM_CFLAGS = $(DRM_CFLAGS) $(CWARNFLAGS) \
+AM_CFLAGS = $(DRM_CFLAGS) $(CWARNFLAGS) $(DEBUG_CFLAGS)\
-I$(srcdir)/.. \
-I$(srcdir)/../lib \
-include "$(srcdir)/../lib/check-ndebug.h" \