summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2009-03-26 17:15:11 -0700
committerEric Anholt <eric@anholt.net>2009-03-26 17:15:11 -0700
commit8c64183a461a422b0443f84622af48858d5fe6ed (patch)
treefd501f110cf01d6986660b3a4d13271d5978078e /tests/Makefile.am
Initial import of intel-graphics-tools with some microbenchmarks.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 00000000..028f764f
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,23 @@
+TESTS = auth \
+ openclose \
+ getversion \
+ getclient \
+ getstats \
+ lock \
+ setversion \
+ updatedraw \
+ gem_basic \
+ gem_flink \
+ gem_readwrite \
+ gem_mmap
+
+EXTRA_LTLIBRARIES = libdrmtest.la
+EXTRA_LTLIBRARIES = libdrmtest.la
+libdrmtest_la_SOURCES = \
+ drmtest.c \
+ drmtest.h
+libdrmtest_la_LIBADD = \
+ $(top_builddir)/libdrm/libdrm.la
+
+EXTRA_PROGRAMS = $(TESTS)
+CLEANFILES = $(EXTRA_PROGRAMS) $(EXTRA_LTLIBRARIES)