summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorDaniel Vetter <daniel.vetter@ffwll.ch>2014-02-04 13:10:37 +0100
committerDaniel Vetter <daniel.vetter@ffwll.ch>2014-02-04 13:10:37 +0100
commit98952a1f6e7e5439e4b77482bd08422212c32e47 (patch)
tree81c1f7f1af9bcfaf9369655d15ce436882c41781 /tests/Makefile.am
parent42bcd05eb3f1545fbf9c397c3f37c3f6a27c5da4 (diff)
fix make distcheck
Bunch of explicit include paths needed adjustments and eviction_common.c needs to be added to the dist files. This has been broken in the following three commits: commit 42bcd05eb3f1545fbf9c397c3f37c3f6a27c5da4 Author: Tvrtko Ursulin <tvrtko.ursulin@intel.com> Date: Mon Feb 3 10:59:41 2014 +0000 tests/eviction_common: Avoid submitting duplicate objects commit b92b397d5e4ffe10ed92fb2fc6711758ef5bcf89 Author: Tvrtko Ursulin <tvrtko.ursulin@intel.com> Date: Tue Dec 3 15:09:57 2013 +0000 build: Make sure asserts are enabled for tests commit 8c33e9ad111d27b84db4daac43809a807f262632 Author: Ben Widawsky <benjamin.widawsky@intel.com> Date: Fri Dec 6 20:35:29 2013 -0800 intel-gpu-tools: Version informatio Cc: Tvrtko Ursulin <tvrtko.ursulin@intel.com> Cc: Ben Widawsky <benjamin.widawsky@intel.com> Signed-off-by: Daniel Vetter <daniel.vetter@ffwll.ch>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index f4a7d415..ac0c0d82 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -16,15 +16,15 @@ list-multi-tests:
@echo END TESTLIST
EXTRA_PROGRAMS = $(TESTS_progs) $(TESTS_progs_M) $(HANG) $(TESTS_testsuite)
-EXTRA_DIST = $(TESTS_scripts) $(TESTS_scripts_M) $(scripts) $(IMAGES)
+EXTRA_DIST = $(TESTS_scripts) $(TESTS_scripts_M) $(scripts) $(IMAGES) $(common_files)
CLEANFILES = $(EXTRA_PROGRAMS)
AM_CFLAGS = $(DRM_CFLAGS) $(CWARNFLAGS) \
-I$(srcdir)/.. \
-I$(srcdir)/../lib \
- -include "check-ndebug.h" \
- -include "$(srcdir)/version.h" \
+ -include "$(srcdir)/../lib/check-ndebug.h" \
+ -include "$(srcdir)/../version.h" \
-DIGT_DATADIR=\""$(abs_srcdir)"\" \
$(NULL)