summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorThomas Wood <thomas.wood@intel.com>2015-12-07 15:12:15 +0000
committerThomas Wood <thomas.wood@intel.com>2015-12-16 16:54:28 +0000
commita012e44b6a68b12e676a4ef48bebe97206fbeb1c (patch)
tree342438c2f86904b2c36e37e06e9bfc32c5609c64 /tests/Makefile.am
parent40798efd859e26386d32ec61272c210685b6a204 (diff)
tests: remove .gitignore and add a Makefile rule to create it
v2: generate the .gitignore file with the default target v3: remove the .gitignore file Signed-off-by: Thomas Wood <thomas.wood@intel.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index c4f1f014..02d52c9f 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -32,12 +32,16 @@ dist_pkgdata_DATA = \
$(IMAGES) \
$(NULL)
+all-local: .gitignore
+.gitignore: Makefile.sources
+ @echo "$(pkglibexec_PROGRAMS) $(HANG) test-list.txt .gitignore" | sed 's/\s\+/\n/g' | sort > $@
+
pkgdata_DATA = test-list.txt
EXTRA_PROGRAMS = $(HANG)
EXTRA_DIST = $(common_files)
-CLEANFILES = $(EXTRA_PROGRAMS) test-list.txt
+CLEANFILES = $(EXTRA_PROGRAMS) test-list.txt .gitignore
AM_CFLAGS = $(DRM_CFLAGS) $(CWARNFLAGS) $(DEBUG_CFLAGS)\
-I$(srcdir)/.. \