summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorDaniel Vetter <daniel.vetter@ffwll.ch>2014-09-18 17:34:27 +0200
committerDaniel Vetter <daniel.vetter@ffwll.ch>2014-09-18 17:36:58 +0200
commita018d60f631443f09da0a2adffc7255a0687f0d8 (patch)
tree16c81a637d8951df2edf05ae793db5f10d782ff8 /tests/Makefile.am
parent25c55d3fc26ec415e0ed290b7d3cda0e15209f66 (diff)
tests: Add drm_import_export
Multithreaded test to validate the (lack of) locking in the flink/open code in libdrm-intel. Based on a testcase from Rafel Sapala. Cc: Rafal Sapala <rafal.a.sapala@intel.com> Signed-off-by: Daniel Vetter <daniel.vetter@ffwll.ch>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index a2fba515..5734002a 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -44,6 +44,8 @@ LDADD = ../lib/libintel_tools.la $(PCIACCESS_LIBS) $(DRM_LIBS)
LDADD += $(CAIRO_LIBS) $(LIBUDEV_LIBS) $(GLIB_LIBS)
AM_CFLAGS += $(CAIRO_CFLAGS) $(LIBUDEV_CFLAGS) $(GLIB_CFLAGS)
+drm_import_export_CFLAGS = $(AM_CFLAGS) $(THREAD_CFLAGS)
+drm_import_export_LDADD = $(LDADD) -lpthread
gem_close_race_CFLAGS = $(AM_CFLAGS) $(THREAD_CFLAGS)
gem_close_race_LDADD = $(LDADD) -lpthread
gem_ctx_basic_CFLAGS = $(AM_CFLAGS) $(THREAD_CFLAGS)