summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorFeceoru, Gabriel <gabriel.feceoru@intel.com>2016-04-20 17:21:58 +0300
committerMarius Vlad <marius.c.vlad@intel.com>2016-04-20 18:16:43 +0300
commita633ad03c6a0e96eecfd4933ea0dffb68ed40e07 (patch)
tree401bc11601f8de4153d409cc2ba0393e0481c5b8 /tests/Makefile.am
parent3450cba30efb554db9de080735fc6a74acca5d4c (diff)
tests: Separate tests with lots of subtests
Currently, when trying to run i-g-t tests with piglit, it takes up to 20s until the first test is executed. The main reason is that gem_concurrent_all has ~500k subtests, overkilling piglit. This patch separates gem_concurrent_* tests from the rest of the tests, creating two files test-list.txt and test-list-full.txt. The piglit can now enumerate the i-g-t tests within a decent few seconds. The second list could be used when trying to execute specific these tests. v2: Rebased Signed-off-by: Gabriel Feceoru <gabriel.feceoru@intel.com> Signed-off-by: Marius Vlad <marius.c.vlad@intel.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 771e9eed..0ed2a078 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -14,6 +14,12 @@ test-list.txt: Makefile.sources
@echo ${single_kernel_tests} ${multi_kernel_tests} >> $@
@echo END TESTLIST >> $@
+test-list-full.txt: Makefile.sources
+ @echo TESTLIST > $@
+ @echo ${single_kernel_tests} ${multi_kernel_tests} ${extra_multi_kernel_tests} >> $@
+ @echo END TESTLIST >> $@
+
+
noinst_PROGRAMS = \
$(HANG) \
$(TESTS_testsuite) \
@@ -38,14 +44,14 @@ dist_pkgdata_DATA = \
all-local: .gitignore
.gitignore: Makefile.sources
- @echo "$(pkglibexec_PROGRAMS) $(HANG) test-list.txt .gitignore" | sed 's/\s\+/\n/g' | sort > $@
+ @echo "$(pkglibexec_PROGRAMS) $(HANG) test-list.txt test-list-full.txt .gitignore" | sed 's/\s\+/\n/g' | sort > $@
-pkgdata_DATA = test-list.txt
+pkgdata_DATA = test-list.txt test-list-full.txt
EXTRA_PROGRAMS = $(HANG)
EXTRA_DIST = $(common_files)
-CLEANFILES = $(EXTRA_PROGRAMS) test-list.txt .gitignore
+CLEANFILES = $(EXTRA_PROGRAMS) test-list.txt test-list-full.txt .gitignore
AM_CFLAGS = $(DRM_CFLAGS) $(CWARNFLAGS) $(DEBUG_CFLAGS)\
-I$(srcdir)/.. \