summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorArkadiusz Hiler <arkadiusz.hiler@intel.com>2017-04-12 12:33:12 +0200
committerArkadiusz Hiler <arkadiusz.hiler@intel.com>2017-06-07 13:28:13 +0300
commita702b60782d713ebce9199b0007d8beb083e49fe (patch)
treec3c07ce00d1583ef52b2a2e57d5f33f6532187fa /tests/Makefile.am
parentd7d3f4e87b827152f00bdf89a67871736672b492 (diff)
chamelium: Fix build issues on Android
Makefile.sources are included 1:1 in Android.mk files, and are not parsed by automake. And yet those had some automake conditional logic. Moving it to .am file is enough for now. Also igt_chamelium.h included config.h without proper "HAVE_CONFIG_H" guard, and the file itself was included unconditionally. Signed-off-by: Arkadiusz Hiler <arkadiusz.hiler@intel.com> Reviewed-by: Michal Wajdeczko <michal.wajdeczko@intel.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 05681d50..61c7a153 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -12,6 +12,12 @@ if HAVE_LIBDRM_VC4
TESTS_progs_M += $(VC4_TESTS_M)
endif
+if HAVE_CHAMELIUM
+TESTS_progs_M += \
+ chamelium \
+ $(NULL)
+endif
+
if BUILD_TESTS
test-list.txt: Makefile.sources
@echo TESTLIST > $@