summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorMaarten Lankhorst <maarten.lankhorst@linux.intel.com>2017-11-21 16:05:20 +0100
committerMaarten Lankhorst <maarten.lankhorst@linux.intel.com>2017-11-22 10:42:33 +0100
commita839b53b790d9bc26cc775fe6a0d0a1e81ee7e1f (patch)
tree96f4f058c24caac10d029da1501be03f314bbbde /tests/Makefile.am
parentd0971c081d9d64465a85a2e6789cb69eecd232a8 (diff)
tests: Regenerate testlist when Makefile is changed, v2.
This fixes the testlist keeping the out-of-date reference to chamelium on last run. Changes since v1: - Remove reference to Makefile.sources, this is already handled by the dependency on Makefile. Signed-off-by: Maarten Lankhorst <maarten.lankhorst@linux.intel.com> Reported-by: Tomi Sarvela <tomi.p.sarvela@intel.com> Cc: Tomi Sarvela <tomi.p.sarvela@intel.com> Acked-by: Tomi Sarvela <tomi.p.sarvela@intel.com> Reviewed-by: Petri Latvala <petri.latvala@intel.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 81e320c3..a4a16838 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -29,12 +29,12 @@ endif
TESTS_progs += testdisplay
if BUILD_TESTS
-test-list.txt: Makefile.sources
+test-list.txt: Makefile
@echo TESTLIST > $@
@echo ${kernel_tests} >> $@
@echo END TESTLIST >> $@
-test-list-full.txt: Makefile.sources
+test-list-full.txt: Makefile
@echo TESTLIST > $@
@echo ${kernel_tests} ${extra_kernel_tests} >> $@
@echo END TESTLIST >> $@