summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTvrtko Ursulin <tvrtko.ursulin@intel.com>2019-03-01 10:25:58 +0000
committerTvrtko Ursulin <tvrtko.ursulin@intel.com>2019-03-04 07:01:17 +0000
commita958d3f60b7718151fd0bafcdd1e4874262f51b8 (patch)
tree1d4145b78196e4734d8d00419d21d569b49a5f33 /tests/Makefile.am
parenta117a5b819a76894fcee02a7cc134aa2b1249c78 (diff)
automake: Make librt mandatory
librt is required by libintel_tools so express it as mandatory in autoconf and also drop explicit mentions from Makefile.am. This also fixes a build warning of: tests/Makefile.am:134: warning: variable 'pm_rc6_residency_LDADD' is defined but no program or tests/Makefile.am:134: library has 'pm_rc6_residency' as canonical name (possible typo) Signed-off-by: Tvrtko Ursulin <tvrtko.ursulin@intel.com> Reviewed-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am5
1 files changed, 1 insertions, 4 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index c5dd210c..289249b4 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -128,10 +128,7 @@ gem_userptr_blits_CFLAGS = $(AM_CFLAGS) $(THREAD_CFLAGS)
gem_userptr_blits_LDADD = $(LDADD) -lpthread
perf_pmu_LDADD = $(LDADD) $(top_builddir)/lib/libigt_perf.la
-gem_eio_LDADD = $(LDADD) -lrt
-gem_wait_LDADD = $(LDADD) -lrt
-kms_flip_LDADD = $(LDADD) -lrt -lpthread
-pm_rc6_residency_LDADD = $(LDADD) -lrt
+kms_flip_LDADD = $(LDADD) -lpthread
prime_nv_test_CFLAGS = $(AM_CFLAGS) $(DRM_NOUVEAU_CFLAGS)
prime_nv_test_LDADD = $(LDADD) $(DRM_NOUVEAU_LIBS)