summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorThomas Wood <thomas.wood@intel.com>2014-04-02 11:41:43 +0100
committerDaniel Vetter <daniel.vetter@ffwll.ch>2014-04-02 13:50:28 +0200
commitd4933259b84a304145634cc6ec5d9eebeb612711 (patch)
tree62faba46a27372a0aada1fd2c911de4891b8894c /tests/Makefile.am
parent22bc1a287eb6c0e7b89001424c895dd776f9a28b (diff)
tests: create files that list the available tests
Add Makefile targets to create two text files containing the list of available single and multi-test programs. This enables the tests to be enumerated without requiring the build system. Signed-off-by: Thomas Wood <thomas.wood@intel.com> Signed-off-by: Daniel Vetter <daniel.vetter@ffwll.ch>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index ba05eac6..c26a3d02 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -5,6 +5,8 @@ if HAVE_NOUVEAU
endif
if BUILD_TESTS
+all-local: single-tests.txt multi-tests.txt
+
list-single-tests:
@echo TESTLIST
@echo ${single_kernel_tests}
@@ -15,10 +17,20 @@ list-multi-tests:
@echo ${multi_kernel_tests}
@echo END TESTLIST
+single-tests.txt:
+ @echo TESTLIST > $@
+ @echo ${single_kernel_tests} >> $@
+ @echo END TESTLIST >> $@
+
+multi-tests.txt:
+ @echo TESTLIST > $@
+ @echo ${multi_kernel_tests} >> $@
+ @echo END TESTLIST >> $@
+
EXTRA_PROGRAMS = $(TESTS_progs) $(TESTS_progs_M) $(HANG) $(TESTS_testsuite)
EXTRA_DIST = $(TESTS_scripts) $(TESTS_scripts_M) $(scripts) $(IMAGES) $(common_files)
-CLEANFILES = $(EXTRA_PROGRAMS)
+CLEANFILES = $(EXTRA_PROGRAMS) single-tests.txt multi-tests.txt
AM_CFLAGS = $(DRM_CFLAGS) $(CWARNFLAGS) \
-I$(srcdir)/.. \