summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorThomas Wood <thomas.wood@intel.com>2015-03-13 14:15:46 +0000
committerThomas Wood <thomas.wood@intel.com>2015-04-14 17:43:05 +0100
commite72686b83b0bb51a0266d61c3024a5f5a6e17af7 (patch)
treefa96e26048bbc0b8f6afe0d69ce8efa4df4130eb /tests/Makefile.am
parentcff102ebb264eb86554651c7cbf259b4342b76c3 (diff)
tests: create a single combined test list
All tests now respond in a consistent way such that separate lists for tests with and without subtests are no longer necessary. v2: fix other references to the test list Signed-off-by: Thomas Wood <thomas.wood@intel.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am23
1 files changed, 4 insertions, 19 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index dc864f4f..11f7f965 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -5,26 +5,11 @@ if HAVE_NOUVEAU
endif
if BUILD_TESTS
-all-local: single-tests.txt multi-tests.txt
+all-local: test-list.txt
-list-single-tests:
- @echo TESTLIST
- @echo ${single_kernel_tests}
- @echo END TESTLIST
-
-list-multi-tests:
- @echo TESTLIST
- @echo ${multi_kernel_tests}
- @echo END TESTLIST
-
-single-tests.txt: Makefile.sources
- @echo TESTLIST > $@
- @echo ${single_kernel_tests} >> $@
- @echo END TESTLIST >> $@
-
-multi-tests.txt: Makefile.sources
+test-list.txt: Makefile.sources
@echo TESTLIST > $@
- @echo ${multi_kernel_tests} >> $@
+ @echo ${single_kernel_tests} ${multi_kernel_tests} >> $@
@echo END TESTLIST >> $@
noinst_PROGRAMS = \
@@ -52,7 +37,7 @@ dist_pkgdata_DATA = \
EXTRA_PROGRAMS = $(HANG)
EXTRA_DIST = $(common_files)
-CLEANFILES = $(EXTRA_PROGRAMS) single-tests.txt multi-tests.txt
+CLEANFILES = $(EXTRA_PROGRAMS) test-list.txt
AM_CFLAGS = $(DRM_CFLAGS) $(CWARNFLAGS) $(DEBUG_CFLAGS)\
-I$(srcdir)/.. \