summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2018-07-26 21:08:44 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2018-07-27 14:01:23 +0100
commitff91dbc87eece221626b184ce33f5b4e62d0d319 (patch)
tree7f5107d2e14d150cb87377fb384fdd6820fc96b6 /tests/Makefile.am
parentb051e16eba17cb7eb36c141db6992830894542db (diff)
igt/gem_mocs_settings: Use i915_pmu to measure rc6 residency
Use the perf pmu interface for lowlevel rc6 measurement, hopefully for greater stability. v2: Fix timeout to run for 1s, not one pass! Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk> Reviewed-by: Matthew Auld <matthew.auld@intel.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 8712eb16..ee5a7c5e 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -115,6 +115,7 @@ gem_fence_upload_CFLAGS = $(AM_CFLAGS) $(THREAD_CFLAGS)
gem_fence_upload_LDADD = $(LDADD) -lpthread
gem_flink_race_CFLAGS = $(AM_CFLAGS) $(THREAD_CFLAGS)
gem_flink_race_LDADD = $(LDADD) -lpthread
+gem_mocs_settings_LDADD = $(LDADD) $(top_builddir)/lib/libigt_perf.la
gem_mmap_gtt_CFLAGS = $(AM_CFLAGS) $(THREAD_CFLAGS)
gem_mmap_gtt_LDADD = $(LDADD) -lpthread
gem_mmap_wc_CFLAGS = $(AM_CFLAGS) $(THREAD_CFLAGS)