summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorPetri Latvala <petri.latvala@intel.com>2018-01-15 13:14:56 +0200
committerPetri Latvala <petri.latvala@intel.com>2018-01-17 14:03:18 +0200
commit4ebf6877926d35c27738d79b127e93c1d1cee5d5 (patch)
treea66cd4721581b44430356186b7b5a7fe56e2b9d7 /tests/meson.build
parentd4e5b77b341010ae1aac8624175650c32913e3fd (diff)
meson: Refactor get_option() calls for directories
Fetch the configuration values in the toplevel meson.build for all subdirs to share. v2: Also remember tests/intel-ci/meson.build Signed-off-by: Petri Latvala <petri.latvala@intel.com> Cc: Daniel Vetter <daniel.vetter@ffwll.ch> Reviewed-by: Daniel Vetter <daniel.vetter@ffwll.ch>
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build6
1 files changed, 1 insertions, 5 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 4c4bee1d..2322217d 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -255,8 +255,6 @@ if alsa.found() and gsl.found()
test_deps += alsa
endif
-libexecdir = join_paths(get_option('prefix'), get_option('libexecdir'), 'intel-gpu-tools')
-
test_executables = []
foreach prog : test_progs
@@ -278,8 +276,6 @@ executable('testdisplay', ['testdisplay.c', 'testdisplay_hotplug.c'],
install : true)
test_progs += 'testdisplay'
-pkgdatadir = join_paths(get_option('prefix'), get_option('datadir'), 'intel-gpu-tools')
-
gen_testlist = find_program('generate_testlist.sh')
test_list = custom_target('testlist',
output : 'test-list.txt',
@@ -318,6 +314,6 @@ image_files = [
'1080p-right.png',
'pass.png',
]
-install_data(sources : image_files, install_dir : pkgdatadir)
+install_data(sources : image_files, install_dir : datadir)
subdir('intel-ci')