summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorArkadiusz Hiler <arkadiusz.hiler@intel.com>2018-08-13 13:16:22 +0300
committerArkadiusz Hiler <arkadiusz.hiler@intel.com>2018-08-13 13:59:44 +0300
commit6cc5ebf11ff6327720f41bbd0a0bd117d6b9edbf (patch)
tree2114be87f36b0e9c7626708587ac6b60761455d9 /tests/meson.build
parent2cd4ae5ee6b385360644ded41d73e070ea81f116 (diff)
meson: Define all the rpath_dirs in one place
So they are located close to the definitions of the corresponding install_dirs and can be reused easily. Cc: Petri Latvala <petri.latvala@intel.com> Signed-off-by: Arkadiusz Hiler <arkadiusz.hiler@intel.com> Reviewed-by: Petri Latvala <petri.latvala@intel.com>
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build22
1 files changed, 0 insertions, 22 deletions
diff --git a/tests/meson.build b/tests/meson.build
index bb6c7627..17deb945 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -239,28 +239,6 @@ if _build_audio and alsa.found() and gsl.found()
test_deps += alsa
endif
-if get_option('use_rpath')
- # Set up runpath for the test executables towards libigt.so.
- # The path should be relative to $ORIGIN so the library is
- # still found properly even if installed to a path other than
- # prefix.
-
- # libdir and libexecdir are pathnames relative to
- # prefix. meson enforces this.
-
- # Start from the executable
- libexecdir_rpathdir = '$ORIGIN'
- # Executables are installed in libexecdir. Add a .. for each
- # directory name in it.
- foreach p : libexecdir.split('/')
- libexecdir_rpathdir = join_paths(libexecdir_rpathdir, '..')
- endforeach
- # Add relative path to libdir
- libexecdir_rpathdir = join_paths(libexecdir_rpathdir, libdir)
-else
- libexecdir_rpathdir = ''
-endif
-
test_executables = []
foreach prog : test_progs