summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorLionel Landwerlin <lionel.g.landwerlin@intel.com>2017-12-14 18:36:02 +0000
committerLionel Landwerlin <lionel.g.landwerlin@intel.com>2018-03-12 12:35:10 +0000
commit7da16024ac6b91f6a1c5a11db6263e01c020131c (patch)
tree3290cb98cf36af962b24da7521202b321d1cd665 /tests/meson.build
parent5b83be6c8285b7391943cadd91d12ece7acf8225 (diff)
tests: add i915 query tests
Add some new tests to cover the i915 query uAPI. The first user of this API is the RCS topology but we expect more to follow. v2: Complete invalid cases (Chris) Some styling (to_user_pointer, etc...) (Chris) New error check, through item.length (Chris) v3: Update for new uAPI iteration (Lionel) v4: Return errno from a single point (Chris) Poising checks (Chris) v5: Add more debug traces (Lionel) Update uAPI (Joonas/Lionel) Make sure Haswell is tested (Lionel) v6: s/query_item/query_items/ (Tvrtko) test that flags fields != 0 fail (Tvrtko) Split kernel writes checks out (Tvrtko) Verify that when an EU is available, so is slice & subslice it belongs to (same with subslice). (Tvrtko) Verify kernel errors out with read only memory (Tvrtko) v7: Add a special Haswell test to verify correct values (Tvrtko) Simplify igt_require() in front of tests (Tvrtko) v8: Reuse the GT field from device info to verify slice/subslices numbers on wider number of platforms (Lionel) v9: Fix invalid number of subslices on GT4 (Lionel) Update comments style (Tvrtko) Test invalid query pointer (Tvrtko) Check topology item minimum length (Tvrtko) Test invalid item data pointers (Tvrtko) Signed-off-by: Lionel Landwerlin <lionel.g.landwerlin@intel.com> Reviewed-by: Tvrtko Ursulin <tvrtko.ursulin@intel.com>
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 689e2911..1176463c 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -144,6 +144,7 @@ test_progs = [
'gen3_render_tiledx_blits',
'gen3_render_tiledy_blits',
'gvt_basic',
+ 'i915_query',
'kms_3d',
'kms_addfb_basic',
'kms_atomic',