summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorArkadiusz Hiler <arkadiusz.hiler@intel.com>2018-07-09 17:27:12 +0300
committerArkadiusz Hiler <arkadiusz.hiler@intel.com>2018-07-27 15:51:58 +0300
commitb051e16eba17cb7eb36c141db6992830894542db (patch)
treeb8fa7d09c3250e77a5a53c1bf438068da2cafa56 /tests/meson.build
parent299880dcc048acf3261639cc31e2f8d5e5054df1 (diff)
meson: Prefix generated rpathdirs to designate their use
Since meson does not have variable scoping it gets confusing if you set different values to the same variable in different places. Let's prefix each generated rpathdir to be more explicit about their intended use and to avoid accidental overwrites. Cc: Daniel Vetter <daniel@ffwll.ch> Cc: Petri Latvala <petri.latvala@intel.com> Signed-off-by: Arkadiusz Hiler <arkadiusz.hiler@intel.com> Reviewed-by: Petri Latvala <petri.latvala@intel.com>
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build18
1 files changed, 9 insertions, 9 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 32c2156c..c1f9fa07 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -250,16 +250,16 @@ if get_option('use_rpath')
# prefix. meson enforces this.
# Start from the executable
- rpathdir = '$ORIGIN'
+ libexecdir_rpathdir = '$ORIGIN'
# Executables are installed in libexecdir. Add a .. for each
# directory name in it.
foreach p : libexecdir.split('/')
- rpathdir = join_paths(rpathdir, '..')
+ libexecdir_rpathdir = join_paths(libexecdir_rpathdir, '..')
endforeach
# Add relative path to libdir
- rpathdir = join_paths(rpathdir, libdir)
+ libexecdir_rpathdir = join_paths(libexecdir_rpathdir, libdir)
else
- rpathdir = ''
+ libexecdir_rpathdir = ''
endif
test_executables = []
@@ -268,28 +268,28 @@ foreach prog : test_progs
test_executables += executable(prog, prog + '.c',
dependencies : test_deps,
install_dir : libexecdir,
- install_rpath : rpathdir,
+ install_rpath : libexecdir_rpathdir,
install : true)
endforeach
test_executables += executable('gem_eio', 'gem_eio.c',
dependencies : test_deps + [ realtime ],
install_dir : libexecdir,
- install_rpath : rpathdir,
+ install_rpath : libexecdir_rpathdir,
install : true)
test_progs += 'gem_eio'
test_executables += executable('perf_pmu', 'perf_pmu.c',
dependencies : test_deps + [ lib_igt_perf ],
install_dir : libexecdir,
- install_rpath : rpathdir,
+ install_rpath : libexecdir_rpathdir,
install : true)
test_progs += 'perf_pmu'
executable('testdisplay', ['testdisplay.c', 'testdisplay_hotplug.c'],
dependencies : test_deps,
install_dir : libexecdir,
- install_rpath : rpathdir,
+ install_rpath : libexecdir_rpathdir,
install : true)
test_progs += 'testdisplay'
@@ -311,7 +311,7 @@ endforeach
executable('gem_stress', 'gem_stress.c',
install : true,
install_dir : libexecdir,
- install_rpath : rpathdir,
+ install_rpath : libexecdir_rpathdir,
dependencies : igt_deps)
# IMPORTANT: These tests here are all disabled because the result in sometime