summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorTvrtko Ursulin <tvrtko.ursulin@intel.com>2018-03-23 11:54:28 +0000
committerTvrtko Ursulin <tvrtko.ursulin@intel.com>2018-03-26 10:20:24 +0100
commitb64843612782b509802fe05f1ba7a2e5cf51cdeb (patch)
treea13c4392c5823d66d4f2a7e2db2d64b104adfa3b /tests/meson.build
parent9d9978aff16949c1a4e1508301d8169a21362ae8 (diff)
tests/gem_eio: Speed up test execution
If we stop relying on regular GPU hangs to be detected, but trigger them manually as soon as we know our batch of interest is actually executing on the GPU, we can dramatically speed up various subtests. This is enabled by the pollable spin batch added in the previous patch. v2: * Test gem_wait after reset/wedge and with reset/wedge after a few predefined intervals since gem_wait invocation. (Chris Wilson) v3: Chris Wilson: * Decrease short test to 1us. * Use POSIX timers instead of signals to avoid interrupting gem_wait. * Improve comment. Signed-off-by: Tvrtko Ursulin <tvrtko.ursulin@intel.com> Suggested-by: Chris Wilson <chris@chris-wilson.co.uk> Cc: Antonio Argenziano <antonio.argenziano@intel.com> Reviewed-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build8
1 files changed, 7 insertions, 1 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 122aefab..4720dfe2 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -40,7 +40,6 @@ test_progs = [
'gem_ctx_switch',
'gem_ctx_thrash',
'gem_double_irq_loop',
- 'gem_eio',
'gem_evict_alignment',
'gem_evict_everything',
'gem_exec_alignment',
@@ -289,6 +288,13 @@ foreach prog : test_progs
install : true)
endforeach
+test_executables += executable('gem_eio', 'gem_eio.c',
+ dependencies : test_deps + [ realtime ],
+ install_dir : libexecdir,
+ install_rpath : rpathdir,
+ install : true)
+test_progs += 'gem_eio'
+
test_executables += executable('perf_pmu', 'perf_pmu.c',
dependencies : test_deps + [ lib_igt_perf ],
install_dir : libexecdir,