summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorVille Syrjälä <ville.syrjala@linux.intel.com>2017-09-11 19:00:01 +0300
committerVille Syrjälä <ville.syrjala@linux.intel.com>2017-09-15 15:18:14 +0300
commitfba59da1339162f84e64016dedec22e639800627 (patch)
treebb40c54c62827437ab6bfd322bd07f069202c7af /tests/meson.build
parentc718ba805208e55d675defe9b2a66852e2ae038c (diff)
meson: Install tests into $libexecdir
autotools installs the tests into $libexecdir. Make meson do the same. v2: Fix tabs vs. spaces (Jordan) Reviewed-by: Jordan Justen <jordan.l.justen@intel.com> Signed-off-by: Ville Syrjälä <ville.syrjala@linux.intel.com>
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build10
1 files changed, 8 insertions, 2 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 4dd5a9c9..6feaafe3 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -255,13 +255,19 @@ if alsa.found() and gsl.found()
test_deps += alsa
endif
+libexecdir = join_paths(get_option('prefix'), get_option('libexecdir'), 'intel-gpu-tools')
+
foreach prog : test_progs
executable(prog, prog + '.c',
- dependencies : test_deps)
+ dependencies : test_deps,
+ install_dir : libexecdir,
+ install : true)
endforeach
executable('testdisplay', ['testdisplay.c', 'testdisplay_hotplug.c'],
- dependencies : test_deps)
+ dependencies : test_deps,
+ install_dir : libexecdir,
+ install : true)
test_progs += 'testdisplay'
run_command('generate_testlist.sh', test_progs)