summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorVijay Purushothaman <vijay.a.purushothaman@intel.com>2012-08-17 18:06:52 +0530
committerDaniel Vetter <daniel.vetter@ffwll.ch>2012-08-21 09:30:29 +0200
commit4fc76adf313f2792b7438f9372321ce3ea66c6c2 (patch)
treef9645fa65a9ef761caa34a33044400282eeac776 /tools/Makefile.am
parent082826de6c66ff76c444434cd56aaf6df80027b3 (diff)
tools: Added intel_dpio_read and intel_dpio_write
In Valleyview the DPLL and lane control registers are accessible only through side band fabric called DPIO. Added two tools to read and write registers residing in this space. v2: Moved the core read/write functions to lib/intel_dpio.c based on Ben's feedback Signed-off-by: Vijay Purushothaman <vijay.a.purushothaman@intel.com> Signed-off-by: Daniel Vetter <daniel.vetter@ffwll.ch>
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index d461f387..71fb087f 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -15,6 +15,8 @@ bin_PROGRAMS = \
intel_reg_write \
intel_reg_read \
intel_forcewaked \
+ intel_dpio_read \
+ intel_dpio_write \
intel_l3_parity
noinst_PROGRAMS = \