summaryrefslogtreecommitdiff
path: root/tools/meson.build
diff options
context:
space:
mode:
authorVille Syrjälä <ville.syrjala@linux.intel.com>2017-09-11 19:00:35 +0300
committerVille Syrjälä <ville.syrjala@linux.intel.com>2017-09-15 15:57:51 +0300
commitbfa8a8ea006681a96a72f5d7611884b835310656 (patch)
tree3fbfa2b129a0241f650b067c6e36e5352b2b42d8 /tools/meson.build
parent6a94b7130ae8a1e12ad161dcb9b79a05dbc45968 (diff)
meson: Build and install intel_l3_parity
v2: Fix spaces vs. tabs (Jordan) Reviewed-by: Jordan Justen <jordan.l.justen@intel.com> Signed-off-by: Ville Syrjälä <ville.syrjala@linux.intel.com>
Diffstat (limited to 'tools/meson.build')
-rw-r--r--tools/meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/tools/meson.build b/tools/meson.build
index 627aaa18..9e088c72 100644
--- a/tools/meson.build
+++ b/tools/meson.build
@@ -57,6 +57,11 @@ endforeach
pkgdatadir = join_paths(get_option('prefix'), get_option('datadir'), 'intel-gpu-tools')
+intel_l3_parity_src = [ 'intel_l3_parity.c', 'intel_l3_udev_listener.c' ]
+executable('intel_l3_parity', sources : intel_l3_parity_src,
+ dependencies : tool_deps,
+ install : true)
+
intel_reg_src = [ 'intel_reg.c', 'intel_reg_decode.c', 'intel_reg_spec.c' ]
executable('intel_reg', sources : intel_reg_src,
dependencies : tool_deps,