summaryrefslogtreecommitdiff
path: root/tools/null_state_gen/Makefile.am
diff options
context:
space:
mode:
authorArmin Reese <armin.c.reese@intel.com>2014-09-05 13:58:11 -0700
committerMika Kuoppala <mika.kuoppala@intel.com>2014-10-10 17:26:27 +0300
commitf246f1ed0c2f5eb0c0dc7d92b3d678ecdbf03539 (patch)
tree3d9a56e1f3b5f8cf324790d72799755f9af9a77b /tools/null_state_gen/Makefile.am
parent0e8ac72d5d608d82a91bb5232badfb872589ac14 (diff)
tools/null_state_gen: Add GEN9 golden context batch buffer creation
Modifications to 'null_state_gen' so it can generate GEN9 golden context batch buffer source for SKL. v2: - rebased on top of gen8 changes (Mika) - fixed state base address command size (Mika) - base address size macro as pages (Mika) v3: - rebased on top of current master (Mika) - removed obsolete #includes (Mika) - added copyright (Mika) - render and component packing added (Mika) Cc: Damien Lespiau <damien.lespiau@intel.com> Cc: Armin Reese <armin.c.reese@intel.com> Cc: Volkin, Bradley D <bradley.d.volkin@intel.com> Reviewed-by: Volkin, Bradley D <bradley.d.volkin@intel.com> (v2) Signed-off-by: Armin Reese <armin.c.reese@intel.com> (v1) Signed-off-by: Mika Kuoppala <mika.kuoppala@intel.com>
Diffstat (limited to 'tools/null_state_gen/Makefile.am')
-rw-r--r--tools/null_state_gen/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/tools/null_state_gen/Makefile.am b/tools/null_state_gen/Makefile.am
index 58fbd538..b131e0d3 100644
--- a/tools/null_state_gen/Makefile.am
+++ b/tools/null_state_gen/Makefile.am
@@ -8,9 +8,10 @@ intel_null_state_gen_SOURCES = \
intel_renderstate_gen6.c \
intel_renderstate_gen7.c \
intel_renderstate_gen8.c \
+ intel_renderstate_gen9.c \
intel_null_state_gen.c
-gens := 6 7 8
+gens := 6 7 8 9
h = /tmp/intel_renderstate_gen$$gen.c
state_headers: intel_null_state_gen