summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am23
1 files changed, 0 insertions, 23 deletions
diff --git a/Makefile.am b/Makefile.am
index 9949679b..1dacb175 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -37,29 +37,6 @@ endif
MAINTAINERCLEANFILES = ChangeLog INSTALL
-.PHONY: version.h.tmp
-version.h.tmp:
- @touch $@
- @if test -d .git; then \
- if which git > /dev/null; then git log -n 1 --oneline | \
- sed 's/^\([^ ]*\) .*/#define IGT_GIT_SHA1 "g\1"/' \
- >> $@ ; \
- fi \
- else \
- echo '#define IGT_GIT_SHA1 "NOT-GIT"' >> $@ ; \
- fi
-
-version.h: version.h.tmp
- @echo "updating version.h"
- @if ! cmp -s version.h.tmp version.h; then \
- mv version.h.tmp version.h ;\
- else \
- rm version.h.tmp ;\
- fi
-
-BUILT_SOURCES = version.h
-CLEANFILES = version.h version.h.tmp
-
.PHONY: ChangeLog INSTALL
INSTALL: