summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 1 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index e13a3b74..1a6f5cb2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -176,11 +176,7 @@ PKG_CHECK_MODULES(XRANDR, xrandr >= 1.3, AC_DEFINE(HAVE_XRANDR, 1, [Have libXran
# for testdisplay
PKG_CHECK_MODULES(CAIRO, [cairo >= 1.12.0])
-PKG_CHECK_MODULES(LIBUDEV, [libudev], [udev=yes], [udev=no])
-AM_CONDITIONAL(HAVE_UDEV, [test "x$udev" = xyes])
-if test x"$udev" = xyes; then
- AC_DEFINE(HAVE_UDEV,1,[Enable udev-based monitor hotplug detection])
-fi
+PKG_CHECK_MODULES(LIBUDEV, [libudev])
PKG_CHECK_MODULES(GLIB, [glib-2.0], [glib=yes], [glib=no])
if test x"$glib" = xyes; then
AC_DEFINE(HAVE_GLIB,1,[Enable glib support])
@@ -210,9 +206,6 @@ if test "x$enable_chamelium" = xyes; then
fi
PKG_CHECK_MODULES(PIXMAN, pixman-1, [],
[AC_MSG_ERROR([Failed to find pixman, required by chamelium.])])
- if test x"$udev" != xyes; then
- AC_MSG_ERROR([Failed to find udev, required by chamelium.])
- fi
if test x"$glib" != xyes; then
AC_MSG_ERROR([Failed to find glib, required by chamelium.])
fi