summaryrefslogtreecommitdiff
path: root/overlay/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'overlay/meson.build')
-rw-r--r--overlay/meson.build13
1 files changed, 12 insertions, 1 deletions
diff --git a/overlay/meson.build b/overlay/meson.build
index afacff5e..8b5c52b4 100644
--- a/overlay/meson.build
+++ b/overlay/meson.build
@@ -51,7 +51,18 @@ gpu_overlay_src += both_x11_src
gpu_overlay_src += 'kms/kms-overlay.c'
-if xrandr.found() and cairo.found()
+leg = find_program('leg', required : false)
+if leg.found()
+ leg_file = custom_target('tracepoint_format',
+ output: 'tracepoint_format.h',
+ input: 'tracepoint_format.leg',
+ command: [leg, '-P', '-o', '@OUTPUT@', '@INPUT@'])
+ gpu_overlay_src += leg_file
+else
+ warning('leg command not found, disabling overlay; try : apt-get install peg')
+endif
+
+if leg.found() and xrandr.found() and cairo.found()
executable('intel-gpu-overlay', gpu_overlay_src,
include_directories : inc,
c_args : gpu_overlay_cflags,