summaryrefslogtreecommitdiff
path: root/runner/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'runner/Makefile.am')
-rw-r--r--runner/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/runner/Makefile.am b/runner/Makefile.am
index 9c13a83c..ddcbf86a 100644
--- a/runner/Makefile.am
+++ b/runner/Makefile.am
@@ -1,6 +1,8 @@
if BUILD_RUNNER
+SUBDIRS = testdata
+
runnerlib = librunner.la
noinst_LTLIBRARIES = $(runnerlib)
librunner_la_SOURCES = \
@@ -28,4 +30,14 @@ AM_CFLAGS = $(JSONC_CFLAGS) \
-I$(srcdir)/../lib \
-D_GNU_SOURCE
+TESTS = runner_test
+check_PROGRAMS = runner_test
+runner_test_SOURCES = runner_tests.c
+runner_test_CFLAGS = -DTESTDATA_DIRECTORY=\"$(abs_builddir)/testdata\" \
+ -I$(top_srcdir)/include/drm-uapi \
+ $(DRM_CFLAGS) $(CAIRO_CFLAGS) $(LIBUDEV_CFLAGS) \
+ -I$(srcdir)/.. \
+ -I$(srcdir)/../lib \
+ -D_GNU_SOURCE
+
endif