summaryrefslogtreecommitdiff
path: root/runner/testdata/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'runner/testdata/Makefile.am')
-rw-r--r--runner/testdata/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/runner/testdata/Makefile.am b/runner/testdata/Makefile.am
new file mode 100644
index 00000000..fe225d8d
--- /dev/null
+++ b/runner/testdata/Makefile.am
@@ -0,0 +1,25 @@
+testdata_progs = no-subtests skippers successtest
+
+noinst_PROGRAMS = $(testdata_progs)
+
+test-list.txt: Makefile
+ @echo TESTLIST > $@
+ @echo ${testdata_progs} >> $@
+ @echo END TESTLIST >> $@
+
+noinst_DATA = test-list.txt
+
+all-local: .gitignore
+.gitignore: Makefile.am
+ @echo "$(testdata_progs) test-list.txt /.gitignore" | sed 's/\s\+/\n/g' | sort > $@
+
+CLEANFILES = test-list.txt .gitignore
+
+AM_CFLAGS = $(CWARNFLAGS) -Wno-unused-result $(DEBUG_CFLAGS) \
+ -I$(top_srcdir)/include/drm-uapi \
+ -I$(srcdir)/../.. \
+ -I$(srcdir)/../../lib \
+ $(DRM_CFLAGS) $(CAIRO_CFLAGS) $(LIBUDEV_CFLAGS) \
+ -D_GNU_SOURCE
+
+LDADD = $(top_builddir)/lib/libintel_tools.la