summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/meson.build b/tests/meson.build
index cedb4ff1..9ec39e08 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -232,14 +232,14 @@ if libdrm_nouveau.found()
test_deps += libdrm_nouveau
endif
-if chamelium.found()
+if _build_chamelium and chamelium.found()
test_progs += [
'kms_chamelium',
]
test_deps += chamelium
endif
-if alsa.found() and gsl.found()
+if _build_audio and alsa.found() and gsl.found()
test_progs += [
'audio',
]