summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 155a99fc..1efeda97 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -258,12 +258,14 @@ endif
libexecdir = join_paths(get_option('prefix'), get_option('libexecdir'), 'intel-gpu-tools')
+test_executables = []
+
foreach prog : test_progs
link = []
if prog == 'perf_pmu'
link += lib_igt_perf
endif
- executable(prog, prog + '.c',
+ test_executables += executable(prog, prog + '.c',
dependencies : test_deps,
install_dir : libexecdir,
link_with : link,
@@ -279,7 +281,7 @@ test_progs += 'testdisplay'
pkgdatadir = join_paths(get_option('prefix'), get_option('datadir'), 'intel-gpu-tools')
gen_testlist = find_program('generate_testlist.sh')
-custom_target('testlist',
+test_list = custom_target('testlist',
output : 'test-list.txt',
command : [ gen_testlist, '@OUTPUT@', test_progs ],
install : true,