summaryrefslogtreecommitdiff
path: root/tools/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tools/meson.build')
-rw-r--r--tools/meson.build18
1 files changed, 9 insertions, 9 deletions
diff --git a/tools/meson.build b/tools/meson.build
index 8ed1ccf4..ae9ba493 100644
--- a/tools/meson.build
+++ b/tools/meson.build
@@ -59,22 +59,22 @@ if get_option('use_rpath')
# enforces this.
# Start from the executable
- rpathdir = '$ORIGIN'
+ tools_rpathdir = '$ORIGIN'
# Executables are installed in bindir. Add a .. for each
# directory name in it.
foreach p : bindir.split('/')
- rpathdir = join_paths(rpathdir, '..')
+ tools_rpathdir = join_paths(tools_rpathdir, '..')
endforeach
# Add relative path to libdir
- rpathdir = join_paths(rpathdir, libdir)
+ tools_rpathdir = join_paths(tools_rpathdir, libdir)
else
- rpathdir = ''
+ tools_rpathdir = ''
endif
foreach prog : tools_progs
executable(prog, prog + '.c',
dependencies : tool_deps,
- install_rpath : rpathdir,
+ install_rpath : tools_rpathdir,
install : true)
endforeach
@@ -85,21 +85,21 @@ if libudev.found()
]
executable('intel_dp_compliance', sources : intel_dp_compliance_src,
dependencies : [tool_deps, libudev],
- install_rpath : rpathdir,
+ install_rpath : tools_rpathdir,
install : true)
endif
intel_l3_parity_src = [ 'intel_l3_parity.c', 'intel_l3_udev_listener.c' ]
executable('intel_l3_parity', sources : intel_l3_parity_src,
dependencies : tool_deps,
- install_rpath : rpathdir,
+ install_rpath : tools_rpathdir,
install : true)
intel_reg_src = [ 'intel_reg.c', 'intel_reg_decode.c', 'intel_reg_spec.c' ]
executable('intel_reg', sources : intel_reg_src,
dependencies : tool_deps,
install : true,
- install_rpath : rpathdir,
+ install_rpath : tools_rpathdir,
c_args : [
'-DIGT_DATADIR="@0@"'.format(join_paths(prefix, datadir)),
])
@@ -118,7 +118,7 @@ shared_library('intel_aubdump', 'aubdump.c',
executable('intel_gpu_top', 'intel_gpu_top.c',
install : true,
- install_rpath : rpathdir,
+ install_rpath : tools_rpathdir,
dependencies : tool_deps + [ lib_igt_perf ])
conf_data = configuration_data()