summaryrefslogtreecommitdiff
path: root/tools/null_state_gen/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/null_state_gen/Makefile.am')
-rw-r--r--tools/null_state_gen/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/tools/null_state_gen/Makefile.am b/tools/null_state_gen/Makefile.am
index b131e0d3..bf8cbdb9 100644
--- a/tools/null_state_gen/Makefile.am
+++ b/tools/null_state_gen/Makefile.am
@@ -1,3 +1,4 @@
+GPU_TOOLS_PATH := $(top_srcdir)
AM_CPPFLAGS = -I$(top_srcdir)
noinst_PROGRAMS = intel_null_state_gen
@@ -14,7 +15,14 @@ intel_null_state_gen_SOURCES = \
gens := 6 7 8 9
h = /tmp/intel_renderstate_gen$$gen.c
-state_headers: intel_null_state_gen
+states: intel_null_state_gen
for gen in $(gens); do \
- ./intel_null_state_gen $$gen >$(h) ;\
+ head -n 22 intel_null_state_gen.c >$(h); \
+ if test -d $(GPU_TOOLS_PATH)/.git; then \
+ echo -n " * Generated by: " >>$(h); \
+ git describe >>$(h); \
+ fi; \
+ echo " */" >>$(h); \
+ echo "" >>$(h); \
+ ./intel_null_state_gen $$gen >>$(h); \
done