summaryrefslogtreecommitdiff
path: root/tools/gator/debian/rules
diff options
context:
space:
mode:
authorPhilippe Langlais <philippe.langlais@stericsson.com>2012-05-24 17:16:17 +0200
committerPhilippe Langlais <philippe.langlais@stericsson.com>2012-05-24 17:16:17 +0200
commit6e1ff8e78958e5ea6871dca4a5ef6076fadcbcc1 (patch)
tree4e17c48118edbe073b49341d95809a8e0b2a8f80 /tools/gator/debian/rules
parented6e65a66f3bcf84dff4ff4e680096b7e40076d5 (diff)
parent09f333ed6069575a71fabc999c4dc39b6594d727 (diff)
Merge remote-tracking branch 'armlt/3.3-armlt-gator-5.10' into stable-linux-ux500-3.3ubuntu-release-12-07ubuntu-release-12-06
Conflicts: drivers/Kconfig
Diffstat (limited to 'tools/gator/debian/rules')
-rwxr-xr-xtools/gator/debian/rules15
1 files changed, 15 insertions, 0 deletions
diff --git a/tools/gator/debian/rules b/tools/gator/debian/rules
new file mode 100755
index 00000000000..c747748ff83
--- /dev/null
+++ b/tools/gator/debian/rules
@@ -0,0 +1,15 @@
+#!/usr/bin/make -f
+
+DEB_HOST_GNU_TYPE = $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE = $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
+ifneq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
+ CROSS_COMPILE ?= $(DEB_HOST_GNU_TYPE)-
+endif
+
+export CROSS_COMPILE
+
+export DH_OPTIONS
+
+%:
+ dh $@