summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorKalle Vahlman <kalle.vahlman@movial.com>2012-06-12 09:12:37 +0300
committerKalle Vahlman <kalle.vahlman@movial.com>2012-06-12 10:05:02 +0300
commit29e8449359cc34702afa308c25b1bace624a7f3c (patch)
treeb6209b98e7bb419866b23e3b246573da8561ca3a /debian/rules
parent48e0affb3f5f5e3b19c8f73b5bd445e538ec37a6 (diff)
Proper packaging for loader communication
The package name is changed to match usual library package naming, plus many other changes
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules27
1 files changed, 27 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..f4c03bd
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,27 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+export DH_VERBOSE=1
+
+%:
+ dh $@
+
+override_dh_auto_configure:
+ make config XALAN=/usr/share/java/xalan2.jar LCD_INSTALLDIR='dist/'
+
+override_dh_auto_build:
+ifeq ($(DEB_HOST_ARCH),i386)
+ make LBITS=32
+endif
+ifeq ($(DEB_HOST_ARCH),amd64)
+ make LBITS=64
+ cp out/out_linux/liblcdriver_x64.so out/out_linux/liblcdriver.so
+endif
+
+override_dh_auto_install: