summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Scheel <julian@jusst.de>2016-03-17 16:03:57 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-04-19 22:33:08 +0200
commit0b467c6b952ba8088eedbc529e8d877301e61c93 (patch)
tree6f575f10d8cdf83ea6cfcf68a1704553bc7ca791
parente903e453be706565fbe2a0d87536bd32c3662092 (diff)
cbootimage: new package
Add package for cbootimage host utility that is able to compile bct files and generate flashable images out of a bct and an image for tegra processors. Signed-off-by: Julian Scheel <julian@jusst.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--package/Config.in.host1
-rw-r--r--package/cbootimage/Config.in.host9
-rw-r--r--package/cbootimage/cbootimage.hash2
-rw-r--r--package/cbootimage/cbootimage.mk13
4 files changed, 25 insertions, 0 deletions
diff --git a/package/Config.in.host b/package/Config.in.host
index ccded799e..c1d40f496 100644
--- a/package/Config.in.host
+++ b/package/Config.in.host
@@ -1,6 +1,7 @@
menu "Host utilities"
source "package/aespipe/Config.in.host"
+ source "package/cbootimage/Config.in.host"
source "package/checkpolicy/Config.in.host"
source "package/cramfs/Config.in.host"
source "package/dfu-util/Config.in.host"
diff --git a/package/cbootimage/Config.in.host b/package/cbootimage/Config.in.host
new file mode 100644
index 000000000..1913afa28
--- /dev/null
+++ b/package/cbootimage/Config.in.host
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_HOST_CBOOTIMAGE
+ bool "host cbootimage"
+ depends on BR2_arm || BR2_armeb
+ help
+ This project provides a tool which compiles BCT (Boot
+ Configuration Table) images to place into the boot flash of
+ a Tegra-based device.
+
+ https://github.com/NVIDIA/cbootimage
diff --git a/package/cbootimage/cbootimage.hash b/package/cbootimage/cbootimage.hash
new file mode 100644
index 000000000..96cf172e3
--- /dev/null
+++ b/package/cbootimage/cbootimage.hash
@@ -0,0 +1,2 @@
+# Locally computed
+sha256 373c108d7b6778c62a33e59ad0cd5ea9ebb379319a0c8b4cf469eaa8bec5521b cbootimage-v1.7.tar.gz
diff --git a/package/cbootimage/cbootimage.mk b/package/cbootimage/cbootimage.mk
new file mode 100644
index 000000000..20b17dde5
--- /dev/null
+++ b/package/cbootimage/cbootimage.mk
@@ -0,0 +1,13 @@
+################################################################################
+#
+# cbootimage
+#
+################################################################################
+
+CBOOTIMAGE_VERSION = v1.7
+CBOOTIMAGE_SITE = $(call github,NVIDIA,cbootimage,$(CBOOTIMAGE_VERSION))
+CBOOTIMAGE_LICENSE = GPLv2
+CBOOTIMAGE_LICENSE_FILES = COPYING
+CBOOTIMAGE_AUTORECONF = YES
+
+$(eval $(host-autotools-package))