summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarlos Santos <casantos@datacom.ind.br>2017-01-20 16:18:54 -0200
committerPeter Korsgaard <peter@korsgaard.com>2017-01-20 21:21:22 +0100
commit126162b9159a185ac1897db1a9956f0379fc1428 (patch)
tree366318ca385a0255986f6bcc4d372352469a0ba2
parent9ad575fef56043cf9693c3fcf559e36f714f7d36 (diff)
poco: avoid build failures on multicore hosts
Parallel build still fails on heavilly multicore machines (e.g. -j25) and hacks likecommit 32f4957b153bdabe7af60d529942aca7d1a4783d do not seem to be effective. Let's simply use MAKE1 for the build step, instead. Fixes: http://autobuild.buildroot.net/results/388/38834ad3013fe79e5e4f75997133f1bd827be6dc Signed-off-by: Carlos Santos <casantos@datacom.ind.br> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
-rw-r--r--package/poco/poco.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/poco/poco.mk b/package/poco/poco.mk
index 4b82c500a..90dfb3434 100644
--- a/package/poco/poco.mk
+++ b/package/poco/poco.mk
@@ -57,8 +57,9 @@ define POCO_CONFIGURE_CMDS
--no-samples)
endef
+# Use $(MAKE1) to avoid failures on heavilly parallel machines (e.g. -j25)
define POCO_BUILD_CMDS
- $(TARGET_MAKE_ENV) $(MAKE) POCO_TARGET_OSARCH=$(ARCH) CROSS_COMPILE=$(TARGET_CROSS) \
+ $(TARGET_MAKE_ENV) $(MAKE1) POCO_TARGET_OSARCH=$(ARCH) CROSS_COMPILE=$(TARGET_CROSS) \
MYSQL_LIBDIR=$(STAGING_DIR)/usr/lib/mysql \
MYSQL_INCDIR=$(STAGING_DIR)/usr/include/mysql \
DEFAULT_TARGET=$(POCO_MAKE_TARGET) -C $(@D)