summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Cavallari <nicolas.cavallari@green-communications.fr>2015-03-27 17:50:36 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-03-27 18:09:36 +0100
commit16359f0facbefd73179ffb9616594e0ebfbb5367 (patch)
tree0cb96a834b2f2040b6ee132dcf287795136dd666
parentd13aa2f9e0c33c573fcf9d998475271910e73207 (diff)
mjpg-streamer: Fix build with ccache enabled.
Quote the TARGET_CC variable, otherwise, if ccache is enabled: [...] make CC=$TARGET_CC [...] is expanded to e.g. [...] make CC=ccache gcc [...] The build succeeds with "make[2]: Nothing to be done for '[...]gcc'". and the program is compiled at "make install" time, with the default host compiler, resulting in a binary that does not run on the target. Signed-off-by: Nicolas Cavallari <nicolas.cavallari@green-communications.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--package/mjpg-streamer/mjpg-streamer.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/mjpg-streamer/mjpg-streamer.mk b/package/mjpg-streamer/mjpg-streamer.mk
index 238542926..e10e9a8b4 100644
--- a/package/mjpg-streamer/mjpg-streamer.mk
+++ b/package/mjpg-streamer/mjpg-streamer.mk
@@ -15,7 +15,7 @@ MJPG_STREAMER_LICENSE_FILES = LICENSE
MJPG_STREAMER_DEPENDENCIES = jpeg
define MJPG_STREAMER_BUILD_CMDS
- $(TARGET_MAKE_ENV) $(MAKE) CC=$(TARGET_CC) -C $(@D)
+ $(TARGET_MAKE_ENV) $(MAKE) CC="$(TARGET_CC)" -C $(@D)
endef
define MJPG_STREAMER_INSTALL_TARGET_CMDS